Write protected error during write of some features

I am working with Aravis 0.8.22 Ubuntu 20.04, using Aligned Vision 1800 - 508C.
I can read values from all the features/ attributes. In addition, most of the write commands work well. However, trying to write to some of the features results in a write-protect error.
2 such features are TriggerMode and SequencerTriggerSource.
I tried to use:
arv_camera_set_string, arv_camera_set_string and even the integer functions.

I am getting the following errors:

[ERROR] [1664556485.806211956]: [TriggerMode] [TriggerMode] [RegTriggerMode] USB3Vision write_memory error (write-protect)

[ERROR] [1664556487.991899734]: [SequencerTriggerSource] [SequencerTriggerSource] [Action1] [(null)] USB3Vision read_memory error (invalid-address)

I also tried to check the status on the original code. For this purpose, I added an error status readout on the original code, sending “&error” as the last parameter of the following command (in the main function)
arv_device_set_string_feature_value(global.pDevice, "TriggerMode", "Off",NULL);
and got the same error.

Finally, it’s working on Windows. I tried to modify the Vimba console example and was able to change both of those features. Also, while using Vimba Viewer on Linux, it worked as well.

Therefore, it seems like more of an access management or USB permission issue rather than code related.

Aravis test output:

michael@michael-HP-EliteBook-850-G2:~/GeniCam/Aravis/aravis-0.8.22$  /usr/local/bin/arv-test-0.8 
Found 1 device
Testing 'Allied Vision:ALVIUM 1800 U-508c'
Genicam:Load                        SUCCESS 
Genicam:Schema                      IGNORED 
Properties:SensorSizeReadout        SUCCESS 
Properties:SensorSizeCheck          IGNORED 
Properties:GainReadout              SUCCESS 
Properties:ExposureTimeReadout      SUCCESS 
MultipleAcquisitionA:BufferCheck    FAILURE 0/10
MultipleAcquisitionA:FrameRate      FAILURE 
SoftwareTrigger:BufferCheck         FAILURE 0/5
MultipleAcquisitionB:BufferCheck    FAILURE 0/10
MultipleAcquisitionB:FrameRate      FAILURE 
SingleAcquisition:BufferCheck       FAILURE 

** (arv-test-0.8:122448): CRITICAL **: 18:24:42.214: arv_buffer_get_chunk_data: assertion 'arv_buffer_has_chunks (buffer)' failed
Chunks:BufferCheck                  FAILURE [ChunkOffsetX] [RegChunkOffsetX] [PortOffsetX] Chunk 0x10000019 not found

Any ideas? any help will be much appreciated!


By default, there is no feature access permission check in Aravis. The error is returned by the device. A possible issue is a wrong calculation of the corresponding register address, or another bug in the genicam related code.

Please open a bug report on github: Issues · AravisProject/aravis · GitHub

A debug log with ARV_DEBUG set to all will help.