Arv-tool-0.8 cannot find camera

Hi @Emmanuel,

I have tried using Aravis (0.8.19) with my USB3.0 camera on a NVIDIA board and it worked. However, when I try to replicate this on another spare NVIDIA board (same model), arv-tool-0.8/arv-viewer-0.8 is unable to find my device.

I have checked that the spare NVIDIA board is able to detect my camera using lsusb and dmesg. Any idea what could be the cause of aravis not being able to detect my camera?

The output of arv-tool-0.8 -d all is as follows:
[16:48:32.461] 🆆 interface> Failed to open USB device
[16:48:32.461] 🅸 interface> Found 0 USB3Vision device (among 7 USB devices)
[16:48:32.463] 🅸 interface> [GvDiscoverSocket::new] Add interface (
[16:48:32.464] 🅸 interface> [GvDiscoverSocket::new] Add interface (
[16:48:32.464] 🅸 interface> [GvDiscoverSocket::new] Add interface (
No device found

any help is deeply appreciated.


It looks like a permission issue.

Did you check the udev permission file is installed correctly ?

Thank you so much for pointing me in the right direction! Managed to resolve it with reinstallation of driver + udev permission file