Arv Viewer Video Display Problems

Hey, I’ve installed the latest arv-viewer from AUR, and am having problems with the video display, for both fake and real cameras. Basically as soon as the play is pressed, the viewer appears, says that it is capturing frames at a particular rate but the window is frozen, as if the area where the video should be displayed is not being updated.

Do you know anything about this issue.

Currenlty running on ArchLinux, with aravis-0.7.3, gstreamer-1.16.2 and with bad, base and good gst-plugins.

Hi Nathan,

Please open a bug on github. It is an issue with embedding of the the gstreamer video output.



HI Emmanuel. I am brand new to aravis and trying to use the arviewer. I am getting the same results described above. I am running on LInux Mint 20.2 (Ubuntu 20.04). I installed all of the dependencies listed in the documentation. When I run the viewer and select either the fake camera or one of my real ones, the image display does not occur in a new window, but gets overlayed on top of the arviewer window and looks exactly like the image shown above. I am hoping this is just a simple configuration problem. Any guidance you can give me is greatly appreciated. Thanks! Erik


I can not reproduce the issue on Ubuntu 20.10, either with the x11 or the Wayland backends.

Here is the corresponding issue: Viewer video output broken on X11 · Issue #345 · AravisProject/aravis · GitHub


Hi Emmanuel. Thanks for the reply. I missed finding that issue, perhaps because it was closed. In any case, I believe I have solved the problem and it is just a missing dependency. I installed this package and the viewer works fine now:

Thanks, and hopefully this will help someone else as well.