Control of a USB3Vision camera lost

Hi team,

Randomly sometimes when I run the “arv-viewer-0.8” it lunches the app and I can see my camera but when I click the actual camera so I can press play it throws the following error:

(arv-viewer-0.8:3354): GLib-CRITICAL **: 18:47:08.755: g_thread_join: assertion ‘thread’ failed

But one fix I have found is physically unplug the camera from ubuntu 22.04.2 LTS
machine and plug it back in. After that the command and everything works fine. I’m using a “Allied Vision” camera. Also here is the output I get when I run the reset device command arv-tool-0.8 control DeviceReset -d all as suggested above


From the log output, it looks like the USB device answers to the libusb standard feature request, but data transfers fail.

It is possibly an incorrect USB endpoint state. May be some call to libusb_clear_halt, or even libusb_reset_device could help. It is difficult to debug this sort of issue without having the device at hand. Any help welcome…


Thank you for your suggestion,

I just ran both of those commands and it printed the device was successfully rest and nothing for the second halt command. However when I try to run any commands or start “arv-viewer-0.8” as soon as i click on camera same error comes. It just seems like its been locked and and even when I open the camrea with Vimba, it just hangs and it times out. The only way to reset it and get it to work is pulling USB out and back in. Or shutdown machine and turn back on. Reboot does not fix it. Seems it needs actual power to be cut from the port. I have also followed some documents suggesting to reset (unbind and bind) the driver and also the device as well. But nothing is working. Not sure what else to do. Client manufacturing plant is very far from me so I cannot ask them to keep turning it off and on or pulling the USB camera out. This dose not happen all the time. Once in a while on reset camera gets into this lock mode and when i try to run the stream it shows this error. Only option left is to get a smart plug so I can cut power to machine remotely and back on. Let me know if you have any other suggestions.

Thanks again for you time,