Flir camera only starting after Spinview


I have succesfully integrated aravis with Baumer and Sentech USB3 cameras. Recently, I started to work with a Flir Camera, model BFS-U3-16S2. The camera is recognized, but no images are streamed neither, on arv-viewer or my software. After executing SpinView from FLIR, the camera works, and it can stream in arv-viewer and my software.

I have gone through all the installation process, and the aravis.rules files.

Any suggestion to avoid goring through the SpinView everythime I restart the computer?

Just for additional information: I’m using a Jetson Xavier NX.

Many thanks


Does anybody know how to solve this problem?. I still didn’t find a solution for it



Still facing this problem. Does anyone have a solution for it?


Hi @Rartigas ,

Please open an issue in Aravis issue tracker on github, and attach there the output of arv-camera-test -d all before and after you have executed SpinView. Press Ctrl+C after a few images have been acquired.


Hi Emmanuel

Thanks for answering. I uploaded a new issue with the output of the arv-camera-test before and after executing the Spinview.


For the record, here is the link to the corresponding github issue:

Hi @Rartigas @Emmanuel ,

I get the same problem on the Jetson Xavier NX, but everying is OK on the Jetson Xavier Nano…

I noticed that interface is USB3.1 for the Jetson NX, but USB3.0 for the Jetson nano. So, is it something wrong for USB3.1?

Have you solved the problem ? How to fix it ?

Hi fwanghuan

I didn’t solved the problem. The point is that I had to move to a Jetson AGX, were the problem is non-existing. I tried a couple of NX with a RAW install and both had the same issue. What I wanted to do, but never implemented, is to mix the Spinnaker library with the Aravis. The reason is that the basic demos from Spinnaker are sufficient to make the camera working, and then continue using it with Aravis.

We have been discussing internally at work the implementation of the Aravis library on a commercial product, but along my collegues we have decided to implement the spinnaker from raw instead. It’s a pitty, since I like the simplicity of Aravis.