Getting Errors on arv-device-test - dont know where to start solving

Hello all,

I am fairly new here. Also new to Aravis, IP camera and actually Linux/Raspberry Pi - nevertheless, I managed to install Aravis on my Pi. It also seems to work so far. However, I get an error message in the ./arv-device-test and don’t know exactly where to start. The arv-viewer-0.8 does also give me errors. Does anyone have a tip for me?
I think it could be a configuration/settings problem, but bot sure about that and how to solve it.

Output of ./arv-device-test:

pi@pi:~/aravis-main/build/tests $ ./arv-device-test
Looking for the first available camera
vendor = Hikvision
model = MV-CA060-10GC
device id = 02D32724056
sensor width = 3072
sensor height = 2048
image width = 3072 (max:3072)
image height = 2048 (max:2048)
horizontal binning = 1 (min:0 - max:-1)
vertical binning = 1 (min:0 - max:-1)
exposure auto mode = Off
gain auto mode = Off
trigger selector = FrameBurstStart
reverse x = FALSE
payload size = 12582912 (0xc00000)
stream port = 49460 (49460)
Frame rate = 6 Hz
Frame rate = 2 Hz
Frame rate = 0 Hz
Frame rate = 1 Hz
Frame rate = 2 Hz
^Cstream port = 49460 (49460)
Processed buffers = 7
Failures = 4
Underruns = 0

Output of ./arv-test-0.8:

pi@pi:~/aravis-main/build/src $ ./arv-test-0.8
Found 1 device
Testing ‘Hikvision:MV-CA060-10GC’
Genicam:Load SUCCESS
Genicam:Schema IGNORED
Properties:SensorSizeReadout SUCCESS
Properties:SensorSizeCheck IGNORED
Properties:GainReadout SUCCESS
Properties:ExposureTimeReadout SUCCESS
MultipleAcquisitionA:BufferCheck SUCCESS 10/10
MultipleAcquisitionA:FrameRate FAILURE 6.66 Hz (expected:10.00 Hz)
SoftwareTrigger:BufferCheck SUCCESS 5/5
MultipleAcquisitionB:BufferCheck FAILURE 5/10
MultipleAcquisitionB:FrameRate FAILURE 4.50 Hz (expected:5.00 Hz)
SingleAcquisition:BufferCheck SUCCESS
Chunks:NoSupport FAILURE
GigEVision:NStreamChannels SUCCESS
GigEVision:StreamChannel SUCCESS

Thank you very much!

Hi,

Welcome here. Thanks for your interest in Aravis !

That is a lot, 12MB for each image. What version of raspberry pi are you using ? What is its network bandwith ?

You probably have a lot of missing packets. Try to run arv-camera-test-0.8 instead of arv-device-test, it will show you some statistics about the data transfer.

You may want to reduce the image size, or frame rate. Have a look at the performance related documentation: Aravis – 0.8: Ethernet Devices

Emmanuel.

Is it a 1000 Mbit connection or more?
If its “ONLY” 1000 Mbit (1000BASE-T) you seem to be trying to push more frames than the network can handle.
Make sure you are running jumbo frames on your network device at max and have the same size in your genicam camera setting. Or if the network/camera can handle it, Use 2.5GBASE-T or better . See if test changes.
Looking at the payload size its 16bits per pixel.
It may be possible to send the frames as Bayer 12bitPacked instead that way you will possibly increase the framerate with some 30%…
Sometimes there is a camera setting for “RESERVED” bandwith not being used. If its decreased your actual framerate might go up.

Tobias, Biologist

Hello,
thanks for the suggestions. The problem was, as you suspected, the package size was too big. I reduced the resolution and now I get pictures. Thank you!