MSVC Conan Install


I’m using VSCode and CMake for a wxwidgets app that can be compiled to run on macOS and windows. I got Aravis running natively on macOS and it works great. Previously I was using Spinnaker for windows, but I would love to switch over to Aravis for both platforms.

Without dropping MSVC, could someone help me understand how I install Aravis on windows? I noticed the docs mentioned the github workflow aravis-msvc.yml but I’m not sure how to proceed. Is there a way to run that workflow locally on my windows machine?

For this particular project, I’d like to use MSVC and not MSYS2 and MinGW.



I did not try by myself, but a github workflow is basically a list of shell commands to run in an operating system container. The MSVC workflow install aravis dependencies using conan, which is itself installed using pip. It should work locally on your machine.

Aravis is compiled using meson, which has a MSVC backend.



I created a conanfile.txt and copied the INPUT_CONANFILE contents to it.

Then from the cmd prompt, I ran the following command.

conan install -s os=“Windows” -s compiler=“Visual Studio” -s compiler.version=“17” -s arch=“x86_64” -s build_type=“Release” -b pcre -b missing -b cascade -if build .

This took some time as expected, but completed without errors.

Next, I ran the following bat files


and relocated the build folder to the aravis root directory. Then I ran the following meson command

meson --prefix C:\aravis\install --buildtype release --pkg-config-path C:\aravis\build -Ddocumentation=disabled -Dgst-plugin=enabled -Dintrospection=disabled -Dusb=enabled -Dviewer=disabled -Dgv-n-buffers=1 . .\build

Next I ran

meson compile -C .\build -v

and then

meson install -C .\build

Seems to have worked, although the viewer was not enabled so that didn’t get built. I tried everything from scratch again with it enabled and it still failed. It needs

but still complained about glib2.0

I’m not sure to understand what is not working. The command line tools ? The viewer ?

I don’t think it is possible to build the viewer currently using MSVC. It requires gtk3 by the way, not gtk4.

Did you see Conflict in Visual Studio Conan file · Issue #694 · AravisProject/aravis · GitHub and ci: enabled gst-plugin for MSVC build; contd from #712 by Fixstars-momoko · Pull Request #719 · AravisProject/aravis · GitHub ?

Ok, I will leave the viewer disabled. Everything else seems to be working!

Thanks for the links, I missed those originally.