No such element or plugin 'aravissrc'

Ubuntu 23.10,
GStreamer Core Library version 1.14.1,
Aravis 0.8,
v4l2loopback v0.12.7

Camera description:

Manufacturer: FLIR
Model: BFLY-PGE-50A2M-CS: 5.0 MP, 13 FPS, Aptina MT9P031, Mono (
Interface: GigE

Camera well observed in Aravis GUI.

Attempting to follow/update:

I have installed Aravis 0.8 (and 0.6 to attempt to follow above link), and set

export GST_PLUGIN_PATH=/usr/local/lib/gstreamer-1.0/:$GST_PLUGIN_PATH

But still

gst-launch-1.0 aravissrc ! videoconvert ! xvimagesink
WARNING: erroneous pipeline: no element "aravissrc"


gst-inspect-1.0 aravissrc:
No such element or plugin 'aravissrc' can be found at /usr/lib/x86_64-linux-gnu/gstreamer-1.0



If the plugin is in /usr/lib/x86_64-linux-gnu/gstreamer-1.0, you should add this directory in GST_PLUGIN_PATH.


Thanks for the quick reply. Yeah, sorry, I didn’t include all my testing, as there has been lots. I tried just that path. I have also tried adding it (to include all paths; example below), but it doesn’t seem to help.

export GST_PLUGIN_PATH=/usr/local/lib/gstreamer-1.0/:/usr/lib/x86_64-linux-gnu/gstreamer-1.0:$GST_PLUGIN_PATH

I observe:

Failed to load plugin '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/': /usr/lib/x86_64-linux-gnu/gstreamer-1.0/ undefined symbol: gst_buffer_add_audio_meta
WARNING: erroneous pipeline: no element "aravissrc"

Also, not sure what “sudo ldconfig” does, but I have attempted that as well.

Again, thank you so much for the helpful project and any assistance!

Try to delete the gstreamer registry, and enable debugging while looking for aravis using gst-inspect:

rm ~/.cache/gstreamer-1.0/registry.x86_64.bin
GST_DEBUG=4 gst-inspect aravis

I removed the registry.


GST_DEBUG=4 gst-inspect aravis

Fails with:

gst-inspect: command not found

I set it with:

export GST_DEBUG=4

And still get

No such element or plugin 'aravissrc'

No other output seems relevant, but can be found:

It looks like the interesting informations are in the next debug level. Try:

GST_DEBUG=5 gst-inspect-1.0 aravis

Please attach the debug output here, google docs are not easy to read.

Yeah, sorry, I didn’t want to clog this with text, so I included human readable pictures as well as the text in the GD above, but I understand. Hrm, but now the debug=5 outputs 4 times the allowable discourse size limit. I threw the output in the GD link above, but let me know if you have a better suggestion.

And now GST_PLUGIN_PATH=/usr/lib/x86_64-linux-gnu/gstreamer-1.0 GST_DEBUG=5 gst-inspect-1.0 aravis ?

I have enabled text file upload.

Sorry again, but Discourse says ‘new users cannot upload attachments’. Sigh. The first part of this huge output is in this new link (it was crashing google docs in the first one):

Same output after running

GST_PLUGIN_PATH=/usr/lib/x86_64-linux-gnu/gstreamer-1.0 GST_DEBUG=5 gst-inspect-1.0 aravis

…after clearing the cash per above. In this new GD link I prove that is there.

But while poking around, I observe:

holds files that appear relevant (gst-codec-info-1.0, etc, pic in GD). Note the odd file structure (No dash and additional folder).

/usr/lib/x86_64-linux-gnu/gstreamer1.0/gstreamer-1.0 # holds files like gst-codec-info-1.0
/usr/lib/x86_64-linux-gnu/gstreamer-1.0 # Holds other relevant gstreamer files

I am not sure how these ended up here or if they are supposed to be there, but can/should I try:

# cp -a /source/. /dest/
cp -a /usr/lib/x86_64-linux-gnu/gstreamer1.0/gstreamer-1.0/ . /usr/lib/x86_64-linux-gnu/gstreamer-1.0


Thank you!!

I also have a fresh laptop I can try this on. But any steps I may have missed or anything else I should try different?

Hello, sorry for the late reply. I attempted the sudo copy paste of the gstreamer to what seemed more appropriate to me, but that did not help.

I tried to install again on a fresh laptop, but stray further from success, as aravissrc still cannot be found, but also on that system I cannot get the camera to be observed in the viewer.

Oi, yoi yoi. Any thoughts or assistance would be greatly appreciated. Let me know any other information you would like to see. Thank you!

Please help.

Any thoughts?