Question about using aravissrc on boot


This might be something simple for some folks but for newbie like myself, I couldn’t figure it out and wanted to ask for some help.

I am looking to run this command on boot -
gst-launch-1.0 aravissrc ! video/x-raw, format=RGB,width=640,height=480 ! videoconvert! video/x-raw,format=YUY2 ! videoconvert ! x264enc bframes=0 key-int-max=45 bitrate=512 tune=zerolatency ! h264parse ! video/x-h264,stream-format=avc,alignment=au,profile=baseline ! kvssink stream-name=" YOUR_STREAM_NAME" storage-size=512 access-key="YOUR_AWS_ID" secret-key="YOUR_AWS_SECRET_KEY: aws-region=" YOUR_AWS_REGION"

I added this command inside of a shell script and was trying to run the script using /etc/rc.local but it hasn’t been working. I tried running the script itself, but I was getting

WARNING: erroneous pipeline: no element “aravissrc”
I added export environment variables, but still no luck. When I run that command on terminal, it works without any issue. Any thoughts on what I am missing?

Would appreciate any feedback!



Welcome here !

You most probably have not installed aravis in the right prefix. By default, the installation prefix is /usr/local, but GStreamer is looking in /usr.

The installation prefix can be changed using --prefix=/usr during ./configure call (or when configuring the meson build if you are using the master branch).

Alternatively, you may want to use gst-launch-1.0 --gst-plugin-load=path/to/libgstaravis.0.6 (or 0.8) foolowed by your pipeline.



A remark: you probably don’t want to start you pipeline in rc.local. I would suggest to create a systemd service, that will take care of the management of the script.